[v1] doc: add recommendation to update to latest openssl version
diff mbox series

Message ID 20201023162028.1619189-1-john.mcnamara@intel.com
State Accepted
Delegated to: akhil goyal
Headers show
Series
  • [v1] doc: add recommendation to update to latest openssl version
Related show

Checks

Context Check Description
ci/travis-robot success Travis build: passed
ci/Intel-compilation success Compilation OK
ci/checkpatch success coding style OK

Commit Message

Mcnamara, John Oct. 23, 2020, 4:20 p.m. UTC
Add recommendation to update to latest OpenSSL version when
using the OpenSSL PMD and to at least version 1.1.1g to avoid
known CVEs.

Signed-off-by: John McNamara <john.mcnamara@intel.com>
---
 doc/guides/cryptodevs/openssl.rst | 24 +++++-------------------
 1 file changed, 5 insertions(+), 19 deletions(-)

Comments

Akhil Goyal Oct. 28, 2020, 11:55 a.m. UTC | #1
> Subject: [dpdk-dev] [PATCH v1] doc: add recommendation to update to latest
> openssl version
> 
> Add recommendation to update to latest OpenSSL version when
> using the OpenSSL PMD and to at least version 1.1.1g to avoid
> known CVEs.
> 
> Signed-off-by: John McNamara <john.mcnamara@intel.com>
> ---
Applied to dpdk-next-crypto

Thanks.

Patch
diff mbox series

diff --git a/doc/guides/cryptodevs/openssl.rst b/doc/guides/cryptodevs/openssl.rst
index ca0f0b43f..848a2e8eb 100644
--- a/doc/guides/cryptodevs/openssl.rst
+++ b/doc/guides/cryptodevs/openssl.rst
@@ -58,27 +58,13 @@  Supported Asymmetric Crypto algorithms:
 Installation
 ------------
 
-To compile openssl PMD, appropriate openssl packages have to be installed
-in the build environment.
+To compile the OpenSSL PMD the openssl library must be installed. It will
+then be picked up by the Meson/Ninja build system.
 
-The newest openssl library version is supported:
+To ensure that you have the latest security fixes it is recommended that you
+use version 1.1.1g or newer.
 
-* 1.0.2h-fips  3 May 2016.
-
-Older versions that were also verified:
-
-* 1.0.1f 6 Jan 2014
-* 1.0.1 14 Mar 2012
-
-For Ubuntu 14.04 LTS these packages have to be installed in the build system:
-
-.. code-block:: console
-
-    sudo apt-get install openssl
-    sudo apt-get install libc6-dev-i386 # for i686-native-linux-gcc target
-
-This code was also verified on Fedora 24.
-This code has NOT been verified on FreeBSD yet.
+* 1.1.1g, 2020-Apr-21. https://www.openssl.org/source/
 
 Initialization
 --------------