mbox series

[v3,0/6] net/af_xdp: make compatible with libbpf v0.8.0

Message ID 20221005095037.997006-1-andrew.rybchenko@oktetlabs.ru (mailing list archive)
Headers show
Series net/af_xdp: make compatible with libbpf v0.8.0 | expand

Message

Andrew Rybchenko Oct. 5, 2022, 9:50 a.m. UTC
Update net/af_xdp build to support libbfp v0.8.0.
Avoid library version based checks, check for function presense
instead.

v3:
    - avoid version-based checks

Andrew Rybchenko (5):
  net/af_xdp: move XDP library presence flag to right branch
  net/af_xdp: make it clear which libxdp version is required
  net/af_xdp: avoid version-based check for shared UMEM
  net/af_xdp: avoid version-based check for program load mech
  net/af_xdp: log errors on XDP program removal failures

Ciara Loftus (1):
  net/af_xdp: make compatible with libbpf v0.8.0

 doc/guides/nics/af_xdp.rst             |  3 +-
 doc/guides/rel_notes/release_22_11.rst |  4 ++
 drivers/net/af_xdp/meson.build         | 47 +++++++++++++-------
 drivers/net/af_xdp/rte_eth_af_xdp.c    | 59 ++++++++++++++++++++++----
 4 files changed, 88 insertions(+), 25 deletions(-)