[dpdk-dev,1/3] add tx crc disable flag

Message ID 1455555325-20046-2-git-send-email-emmericp@net.in.tum.de (mailing list archive)
State Changes Requested, archived
Delegated to: Bruce Richardson
Headers

Commit Message

Paul Emmerich Feb. 15, 2016, 4:55 p.m. UTC
  Signed-off-by: Paul Emmerich <emmericp@net.in.tum.de>
---
 lib/librte_mbuf/rte_mbuf.c | 1 +
 lib/librte_mbuf/rte_mbuf.h | 6 ++++++
 2 files changed, 7 insertions(+)
  

Comments

Olivier Matz March 4, 2016, 9:18 a.m. UTC | #1
Hi Paul,

On 02/15/2016 05:55 PM, Paul Emmerich wrote:
> Signed-off-by: Paul Emmerich <emmericp@net.in.tum.de>
> ---
>  lib/librte_mbuf/rte_mbuf.c | 1 +
>  lib/librte_mbuf/rte_mbuf.h | 6 ++++++
>  2 files changed, 7 insertions(+)
> 
> diff --git a/lib/librte_mbuf/rte_mbuf.c b/lib/librte_mbuf/rte_mbuf.c
> index f506517..744fb4e 100644
> --- a/lib/librte_mbuf/rte_mbuf.c
> +++ b/lib/librte_mbuf/rte_mbuf.c
> @@ -270,6 +270,7 @@ const char *rte_get_rx_ol_flag_name(uint64_t mask)
>  const char *rte_get_tx_ol_flag_name(uint64_t mask)
>  {
>  	switch (mask) {
> +	case PKT_TX_NO_CRC_CSUM: return "PKT_TX_NO_CRC_CSUM";
>  	case PKT_TX_VLAN_PKT: return "PKT_TX_VLAN_PKT";
>  	case PKT_TX_IP_CKSUM: return "PKT_TX_IP_CKSUM";
>  	case PKT_TX_TCP_CKSUM: return "PKT_TX_TCP_CKSUM";
> diff --git a/lib/librte_mbuf/rte_mbuf.h b/lib/librte_mbuf/rte_mbuf.h
> index ab6de67..096d84a 100644
> --- a/lib/librte_mbuf/rte_mbuf.h
> +++ b/lib/librte_mbuf/rte_mbuf.h
> @@ -106,6 +106,12 @@ extern "C" {
>  /* add new TX flags here */
>  
>  /**
> + * Disable CRC checksum offload
> + */
> +#define PKT_TX_NO_CRC_CSUM   (1ULL << 49)
> +
> +
> +/**
>   * TCP segmentation offload. To enable this offload feature for a
>   * packet to be transmitted on hardware supporting TSO:
>   *  - set the PKT_TX_TCP_SEG flag in mbuf->ol_flags (this flag implies
> 

The patch does not apply properly. It seems you've done it on a version
that is more than 6 months old. Could you please rebase it?

My second question concerns the behavior of this flag when it is not
supported by the driver. Shouldn't we have a feature flag saying "this
driver supports CRC stripping"?

Also, I think "PKT_TX_STRIP_CRC" would be a better name.

Regards,
Olivier
  

Patch

diff --git a/lib/librte_mbuf/rte_mbuf.c b/lib/librte_mbuf/rte_mbuf.c
index f506517..744fb4e 100644
--- a/lib/librte_mbuf/rte_mbuf.c
+++ b/lib/librte_mbuf/rte_mbuf.c
@@ -270,6 +270,7 @@  const char *rte_get_rx_ol_flag_name(uint64_t mask)
 const char *rte_get_tx_ol_flag_name(uint64_t mask)
 {
 	switch (mask) {
+	case PKT_TX_NO_CRC_CSUM: return "PKT_TX_NO_CRC_CSUM";
 	case PKT_TX_VLAN_PKT: return "PKT_TX_VLAN_PKT";
 	case PKT_TX_IP_CKSUM: return "PKT_TX_IP_CKSUM";
 	case PKT_TX_TCP_CKSUM: return "PKT_TX_TCP_CKSUM";
diff --git a/lib/librte_mbuf/rte_mbuf.h b/lib/librte_mbuf/rte_mbuf.h
index ab6de67..096d84a 100644
--- a/lib/librte_mbuf/rte_mbuf.h
+++ b/lib/librte_mbuf/rte_mbuf.h
@@ -106,6 +106,12 @@  extern "C" {
 /* add new TX flags here */
 
 /**
+ * Disable CRC checksum offload
+ */
+#define PKT_TX_NO_CRC_CSUM   (1ULL << 49)
+
+
+/**
  * TCP segmentation offload. To enable this offload feature for a
  * packet to be transmitted on hardware supporting TSO:
  *  - set the PKT_TX_TCP_SEG flag in mbuf->ol_flags (this flag implies