mbox

[v6,0/2] rte_flow: introduce eCPRI item for rte_flow

Message ID 1594560903-313858-1-git-send-email-bingz@mellanox.com (mailing list archive)
Headers

Message

Bing Zhao July 12, 2020, 1:35 p.m. UTC
  This patch set contains two commits.
1. header definition of the ethdev API
2. testpmd support for the eCPRI flow item

---
v2: Add dw0 for the eCPRI common header to switch the endianess, and
    use fixed u32 value with big-endian for rte_flow_item_ecpri_mask.
    It is due to the fact that global variable only support constant
    expression in C when building.
v3: Add commit for testpmd support.
v4: update release notes part.
v5: fix type#6 define, add event indication macros, and comments for
    revisions.
v6: 1. change the doxygen format into standard format
    2. change the members definition of 'struct rte_ecpri_common_hdr'
    3. fix the missing '^' in prog guide
    4. change the address define in type #4, removed '__packed__'
    5. change the name of 'rte_ecpri_msg_hdr'
       to 'rte_ecpri_combined_msg_hdr'
---

Bing Zhao (2):
  rte_flow: add eCPRI key fields to flow API
  app/testpmd: add eCPRI in flow creation patterns

 app/test-pmd/cmdline_flow.c            | 144 ++++++++++++++++++++++++++
 doc/guides/prog_guide/rte_flow.rst     |   8 ++
 doc/guides/rel_notes/release_20_08.rst |   5 +
 lib/librte_ethdev/rte_flow.c           |   1 +
 lib/librte_ethdev/rte_flow.h           |  33 ++++++
 lib/librte_net/Makefile                |   1 +
 lib/librte_net/meson.build             |   3 +-
 lib/librte_net/rte_ecpri.h             | 183 +++++++++++++++++++++++++++++++++
 lib/librte_net/rte_ether.h             |   1 +
 9 files changed, 378 insertions(+), 1 deletion(-)
 create mode 100644 lib/librte_net/rte_ecpri.h