[0/3] move mbuf definition into a separate file
Message ID | 20190816125304.29719-1-konstantin.ananyev@intel.com (mailing list archive) |
---|---|
Headers |
Return-Path: <dev-bounces@dpdk.org> X-Original-To: patchwork@dpdk.org Delivered-To: patchwork@dpdk.org Received: from [92.243.14.124] (localhost [127.0.0.1]) by dpdk.org (Postfix) with ESMTP id 7C59E1BE9E; Fri, 16 Aug 2019 14:53:21 +0200 (CEST) Received: from mga17.intel.com (mga17.intel.com [192.55.52.151]) by dpdk.org (Postfix) with ESMTP id 25FA61BE93 for <dev@dpdk.org>; Fri, 16 Aug 2019 14:53:19 +0200 (CEST) X-Amp-Result: SKIPPED(no attachment in message) X-Amp-File-Uploaded: False Received: from orsmga007.jf.intel.com ([10.7.209.58]) by fmsmga107.fm.intel.com with ESMTP/TLS/DHE-RSA-AES256-GCM-SHA384; 16 Aug 2019 05:53:18 -0700 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.64,393,1559545200"; d="scan'208";a="168043844" Received: from sivswdev08.ir.intel.com ([10.237.217.47]) by orsmga007.jf.intel.com with ESMTP; 16 Aug 2019 05:53:16 -0700 From: Konstantin Ananyev <konstantin.ananyev@intel.com> To: dev@dpdk.org Cc: michel@digirati.com.br, olivier.matz@6wind.com, anatoly.burakov@intel.com, vipin.varghese@intel.com, Konstantin Ananyev <konstantin.ananyev@intel.com> Date: Fri, 16 Aug 2019 13:53:01 +0100 Message-Id: <20190816125304.29719-1-konstantin.ananyev@intel.com> X-Mailer: git-send-email 2.18.0 Subject: [dpdk-dev] [PATCH 0/3] move mbuf definition into a separate file X-BeenThere: dev@dpdk.org X-Mailman-Version: 2.1.15 Precedence: list List-Id: DPDK patches and discussions <dev.dpdk.org> List-Unsubscribe: <https://mails.dpdk.org/options/dev>, <mailto:dev-request@dpdk.org?subject=unsubscribe> List-Archive: <http://mails.dpdk.org/archives/dev/> List-Post: <mailto:dev@dpdk.org> List-Help: <mailto:dev-request@dpdk.org?subject=help> List-Subscribe: <https://mails.dpdk.org/listinfo/dev>, <mailto:dev-request@dpdk.org?subject=subscribe> Errors-To: dev-bounces@dpdk.org Sender: "dev" <dev-bounces@dpdk.org> |
Message
Ananyev, Konstantin
Aug. 16, 2019, 12:53 p.m. UTC
Right now inclusion of rte_mbuf.h header can cause inclusion of some arch/os specific headers. That prevents it to be included directly by some non-DPDK (but related) entities: KNI, BPF programs, etc. To overcome that problem usually a separate definitions of rte_mbuf structure is created within these entities. That aproach has a lot of drawbacks: code duplication, error prone, etc. This series moves rte_mbuf structure definition (and some related macros) into a separate file that can be included by both rte_mbuf.h and other non-DPDK entities. Note that these moves shouldn't introduce any change for current DPDK code. Konstantin Ananyev (3): eal: move CACHE and IOVA related definitions mbuf: move mbuf definition into a separate file examples/bpf: remove duplicate mbuf definition examples/bpf/t2.c | 5 +- examples/bpf/t3.c | 3 +- lib/librte_eal/common/include/rte_common.h | 44 ++ lib/librte_eal/common/include/rte_memory.h | 38 - lib/librte_mbuf/Makefile | 5 +- lib/librte_mbuf/meson.build | 3 +- lib/librte_mbuf/rte_mbuf.h | 738 +----------------- .../mbuf.h => lib/librte_mbuf/rte_mbuf_core.h | 556 ++++++++----- 8 files changed, 428 insertions(+), 964 deletions(-) rename examples/bpf/mbuf.h => lib/librte_mbuf/rte_mbuf_core.h (51%)