[v6,2/2] mbuf: add bulk free function
Checks
Commit Message
Add function for freeing a bulk of mbufs.
v6:
* Remove __rte_always_inline from static function.
The compiler will inline anyway.
v5:
* Rename variables from "free" to "pending" for improved readability.
* Add prefix __ to rte_pktmbuf_free_seg_via_array().
* Add array size parameter to __rte_pktmbuf_free_seg_via_array().
The compiler will optimize the parameter away anyway.
* Add description to __rte_pktmbuf_free_seg_via_array().
* Minor description updates.
v4:
* Mark as experimental by adding __rte_experimental.
* Add function to experimental section of map file.
* Fix source code formatting regarding pointer to pointer.
* Squash multiple modifications into one.
v3:
* Bugfix: Handle pakets with multiple segments.
* Add inline helper function, mainly for readability.
* Fix source code formatting regarding indentation.
v2:
* Function is not inline.
* Optimize to free multible mbufs belonging to the same mempool in
bulk. Inspired by ixgbe_tx_free_bufs(), but allowing NULL pointers
in the array, just like rte_pktmbuf_free() can take a NULL pointer.
* Use unsigned int instead of unsigned. Passes checkpatch, but
mismatches the original coding style of the modified files.
* Fix a typo in the description headline: mempools is plural.
Signed-off-by: Morten Brørup <mb@smartsharesystems.com>
---
lib/librte_mbuf/rte_mbuf.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
@@ -261,7 +261,7 @@ int rte_mbuf_check(const struct rte_mbuf *m, int is_header,
* Note: The compiler should optimize this parameter away when using a
* constant value, such as RTE_PKTMBUF_FREE_PENDING_SZ.
*/
-static __rte_always_inline void
+static void
__rte_pktmbuf_free_seg_via_array(struct rte_mbuf *m,
struct rte_mbuf ** const pending, unsigned int * const nb_pending,
const unsigned int pending_sz)