From patchwork Thu Oct 10 09:34:56 2019 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 8bit X-Patchwork-Submitter: =?utf-8?q?Morten_Br=C3=B8rup?= X-Patchwork-Id: 60872 Return-Path: X-Original-To: patchwork@dpdk.org Delivered-To: patchwork@dpdk.org Received: from [92.243.14.124] (localhost [127.0.0.1]) by dpdk.org (Postfix) with ESMTP id 196D61E8D6; Thu, 10 Oct 2019 11:35:07 +0200 (CEST) Received: from smartserver.smartsharesystems.com (smartserver.smartsharesystems.com [77.243.40.215]) by dpdk.org (Postfix) with ESMTP id 0088F1E870 for ; Thu, 10 Oct 2019 11:35:00 +0200 (CEST) Received: from dkrd2.smartsharesys.local ([192.168.4.12]) by smartserver.smartsharesystems.com with Microsoft SMTPSVC(6.0.3790.4675); Thu, 10 Oct 2019 11:35:00 +0200 From: =?utf-8?q?Morten_Br=C3=B8rup?= To: dev@dpdk.org Cc: olivier.matz@6wind.com, stephen@networkplumber.org, harry.van.haaren@intel.com, konstantin.ananyev@intel.com, mattias.ronnblom@ericsson.com, bruce.richardson@intel.com, arybchenko@solarflare.com, =?utf-8?q?Morten_Br=C3=B8rup?= Date: Thu, 10 Oct 2019 09:34:56 +0000 Message-Id: <20191010093456.47037-3-mb@smartsharesystems.com> X-Mailer: git-send-email 2.17.1 In-Reply-To: <20191010093456.47037-1-mb@smartsharesystems.com> References: <20191010093456.47037-1-mb@smartsharesystems.com> MIME-Version: 1.0 X-OriginalArrivalTime: 10 Oct 2019 09:35:00.0244 (UTC) FILETIME=[FC7B3540:01D57F4D] Subject: [dpdk-dev] [PATCH v6 2/2] mbuf: add bulk free function X-BeenThere: dev@dpdk.org X-Mailman-Version: 2.1.15 Precedence: list List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" Add function for freeing a bulk of mbufs. Signed-off-by: Morten Brørup Acked-by: Konstantin Ananyev Reviewed-by: Andrew Rybchenko --- v6: * Remove __rte_always_inline from static function. The compiler will inline anyway. v5: * Rename variables from "free" to "pending" for improved readability. * Add prefix __ to rte_pktmbuf_free_seg_via_array(). * Add array size parameter to __rte_pktmbuf_free_seg_via_array(). The compiler will optimize the parameter away anyway. * Add description to __rte_pktmbuf_free_seg_via_array(). * Minor description updates. v4: * Mark as experimental by adding __rte_experimental. * Add function to experimental section of map file. * Fix source code formatting regarding pointer to pointer. * Squash multiple modifications into one. v3: * Bugfix: Handle pakets with multiple segments. * Add inline helper function, mainly for readability. * Fix source code formatting regarding indentation. v2: * Function is not inline. * Optimize to free multible mbufs belonging to the same mempool in bulk. Inspired by ixgbe_tx_free_bufs(), but allowing NULL pointers in the array, just like rte_pktmbuf_free() can take a NULL pointer. * Use unsigned int instead of unsigned. Passes checkpatch, but mismatches the original coding style of the modified files. * Fix a typo in the description headline: mempools is plural. --- lib/librte_mbuf/rte_mbuf.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/lib/librte_mbuf/rte_mbuf.c b/lib/librte_mbuf/rte_mbuf.c index de5659baa..854af1104 100644 --- a/lib/librte_mbuf/rte_mbuf.c +++ b/lib/librte_mbuf/rte_mbuf.c @@ -261,7 +261,7 @@ int rte_mbuf_check(const struct rte_mbuf *m, int is_header, * Note: The compiler should optimize this parameter away when using a * constant value, such as RTE_PKTMBUF_FREE_PENDING_SZ. */ -static __rte_always_inline void +static void __rte_pktmbuf_free_seg_via_array(struct rte_mbuf *m, struct rte_mbuf ** const pending, unsigned int * const nb_pending, const unsigned int pending_sz)