get:
Show a patch comment.

patch:
Update a patch comment.

put:
Update a patch comment.

GET /api/patches/139746/comments/169980/?format=api
HTTP 200 OK
Allow: GET, PUT, PATCH, HEAD, OPTIONS
Content-Type: application/json
Vary: Accept

{
    "id": 169980,
    "web_url": "http://patchwork.dpdk.org/comment/169980/",
    "msgid": "<CAKXZ7egvSVZ9Yr57twKOroBxMEh8vMNZ2DsgAM68Gnu92jCXOQ@mail.gmail.com>",
    "list_archive_url": "https://inbox.dpdk.org/dev/CAKXZ7egvSVZ9Yr57twKOroBxMEh8vMNZ2DsgAM68Gnu92jCXOQ@mail.gmail.com",
    "date": "2024-05-15T15:12:43",
    "subject": "Re: [PATCH v5 2/2] dts: Change hugepage 'amount' to a different term",
    "submitter": {
        "id": 3281,
        "url": "http://patchwork.dpdk.org/api/people/3281/?format=api",
        "name": "Nicholas Pratte",
        "email": "npratte@iol.unh.edu"
    },
    "content": "On Mon, May 13, 2024 at 6:06 AM Juraj Linkeš <juraj.linkes@pantheon.tech> wrote:\n>\n> On Tue, May 7, 2024 at 3:00 PM Bruce Richardson\n> <bruce.richardson@intel.com> wrote:\n> >\n> > On Tue, May 07, 2024 at 01:43:30PM +0100, Luca Vizzarro wrote:\n> > > On 07/05/2024 13:05, Bruce Richardson wrote:\n> > > > Sorry to be late to the reviews here, but since this is a countable value -\n> > > > as you state in the cover letter- would \"number\" or \"count\" not be better\n> > > > terms. To me, \"quantity\" is just a synonym of \"amount\", and can be used for\n> > > > uncountable values too, e.g. \"a quantity of water\".\n> > >\n> > >\n> > > Hi Bruce,\n> > >\n> > > The change is based on the readability and intuitiveness of the\n> > > configuration file. In which case \"number\" could be ambiguous:\n> > >\n> > >   hugepages_2mb:\n> > >     number: 100\n> > >\n> > > And here I could see \"count\" working:\n> > >\n> > >   hugepages_2mb:\n> > >     count: 100\n> > >\n>\n> We could use number_of: but that doesn't look great. Count looks fine.\n\nI personally think that number_of is the better option of the two.\nCount does work, but to me, it's not as immediately clear as\nnumber_of; syntactically, it makes more sense.\n\n>\n> > > But since the change is propagated for consistency. \"count\" would no longer\n> > > be well fitting in the rest:\n> > >\n> > >      \"description\": \"The count of hugepages to configure. Hugepage\n> > >                      size will be the system default.\"\n> > >\n> > Whatever term is actually used, the description should definitely refer to\n> > \"The number of hugepages to configure\".\n>\n> This makes sense, let's use \"number of\" in descriptions.\n\nI will make the change as requested.\n\n>\n> Ideally we'd also use number in code, but it's a bit ambiguous, such as here:\n> def _configure_huge_pages(self, number: int, size: int,\n> force_first_numa: bool) -> None:\n>\n> At a first glance it's not quite clear what \"number\" is here.\n> \"number_of\" would be pretty clear, but so would be \"count\". But using\n> count would mean we're using different words with the same meaning in\n> the same context, which I'd also like to avoid - this is the reason\n> why I was originally ok with quantity. Now I'm not sure what the best\n> option is :-)\n\nNow that you mention it, and given Bruce's comments regarding the use\nof quantity, I really like the use of number_of throughout the\nframework and even the conf.yaml. Doing so will create consistency in\nboth the framework's internal documentation (like the 'number of'\nsuggestion above) and the code, removing the ambiguity that you\nmentioned in some of the definitions.",
    "headers": {
        "Return-Path": "<dev-bounces@dpdk.org>",
        "X-Original-To": "patchwork@inbox.dpdk.org",
        "Delivered-To": "patchwork@inbox.dpdk.org",
        "Received": [
            "from mails.dpdk.org (mails.dpdk.org [217.70.189.124])\n\tby inbox.dpdk.org (Postfix) with ESMTP id D0E2243FD4;\n\tWed, 15 May 2024 17:12:57 +0200 (CEST)",
            "from mails.dpdk.org (localhost [127.0.0.1])\n\tby mails.dpdk.org (Postfix) with ESMTP id 5E6CE402AD;\n\tWed, 15 May 2024 17:12:57 +0200 (CEST)",
            "from mail-lj1-f181.google.com (mail-lj1-f181.google.com\n [209.85.208.181])\n by mails.dpdk.org (Postfix) with ESMTP id 732CD4021D\n for <dev@dpdk.org>; Wed, 15 May 2024 17:12:55 +0200 (CEST)",
            "by mail-lj1-f181.google.com with SMTP id\n 38308e7fff4ca-2e2da49e86bso10950811fa.0\n for <dev@dpdk.org>; Wed, 15 May 2024 08:12:55 -0700 (PDT)"
        ],
        "DKIM-Signature": "v=1; a=rsa-sha256; c=relaxed/relaxed;\n d=iol.unh.edu; s=unh-iol; t=1715785975; x=1716390775; darn=dpdk.org;\n h=content-transfer-encoding:cc:to:subject:message-id:date:from\n :in-reply-to:references:mime-version:from:to:cc:subject:date\n :message-id:reply-to;\n bh=vUQhVuJDQcdawObyOVG4BokMNbbFPHe6H+bkCf/K4LY=;\n b=ZKG5vmVp0aAaHICgbvfkgMtOVgT74G74HG4+187bmOJkeFsA/dpMKuswChZ8Frzbv2\n 6vmHc24xDgFCcYoA8jeru5KM0DMhacHhhi0H5BlKaC28iflFULNmF9SrK+H1JgDRpBlT\n nNoD/7SiwKCIjTceNs0Yg002DLiFoLt/jJ9uk=",
        "X-Google-DKIM-Signature": "v=1; a=rsa-sha256; c=relaxed/relaxed;\n d=1e100.net; s=20230601; t=1715785975; x=1716390775;\n h=content-transfer-encoding:cc:to:subject:message-id:date:from\n :in-reply-to:references:mime-version:x-gm-message-state:from:to:cc\n :subject:date:message-id:reply-to;\n bh=vUQhVuJDQcdawObyOVG4BokMNbbFPHe6H+bkCf/K4LY=;\n b=saqm8gv7JvxNdJ+f0D0GRyorFIRUP5bwUSgZodOKO/8RX91Qxc4O71LuSAkcBB7vSL\n 6EHHOF6WVOUdiZs1mrTaLQRdDfmp1iLgb/6FjaW8xBAV1I7vvM7sN6OM9N5w5Va75Jdi\n DxUBexrG2862yXX0lApIJ2jOe9+fysNjCU63kkcqm5j8d9IC/X3EcOLZtr5F+iJRt60M\n bwievtNycou/jg+oL57IUrrHbLfpTs/gpcf9scTewg91+TDTWjwBh2DWKsFzmPfVxt10\n MXvxA7UDtQzBSwowrPEy0daONYS+2qYkgFkrczDHG/mBZPoq85TdxUI7h07vBXLpJIqV\n 5gIg==",
        "X-Forwarded-Encrypted": "i=1;\n AJvYcCXuxHup0j0qdfIHkTtReQOMAhnGKSqn8M4zqtX77Hs7+N1qfnRQcywgs86yeDn1+k2EpM2ySpxc0GMri24=",
        "X-Gm-Message-State": "AOJu0YwZcVXevhOYgRB2abCYz2h2mY9DEy/5UQZA6ka3e+NvdVYCDzrF\n uU6rfymCZzE/L9zZomxhryOmWclU79KfsQoCP1G+NqLJZQCtmdS8CpW/JIOr3tRlY4oPl3BHvh8\n osZTQryv6xS/SjQIMDYS5CXHveOWJOQ2J9VOvFw==",
        "X-Google-Smtp-Source": "\n AGHT+IEee7k3XnbAu+QotFuJBjiWVtsQnPvRrnQDwX8LwGws339GIadydkqOfL07dl5W2O3uE51atkvmMGsamhfZZ84=",
        "X-Received": "by 2002:a2e:b015:0:b0:2e3:ba0e:de02 with SMTP id\n 38308e7fff4ca-2e5205eb315mr119150341fa.5.1715785974775; Wed, 15 May 2024\n 08:12:54 -0700 (PDT)",
        "MIME-Version": "1.0",
        "References": "<20240430184533.29247-2-npratte@iol.unh.edu>\n <20240430184533.29247-3-npratte@iol.unh.edu>\n <ZjoY_4zoYnp5BW8T@bricha3-mobl1.ger.corp.intel.com>\n <d03f474a-c040-46aa-925a-812c7388617f@arm.com>\n <Zjol1w3ClLi1MLYP@bricha3-mobl1.ger.corp.intel.com>\n <CAOb5WZaY+3BJW0fOowBuEE+7wiqEEwzT_sZOiOUtTQjjthLhSw@mail.gmail.com>",
        "In-Reply-To": "\n <CAOb5WZaY+3BJW0fOowBuEE+7wiqEEwzT_sZOiOUtTQjjthLhSw@mail.gmail.com>",
        "From": "Nicholas Pratte <npratte@iol.unh.edu>",
        "Date": "Wed, 15 May 2024 11:12:43 -0400",
        "Message-ID": "\n <CAKXZ7egvSVZ9Yr57twKOroBxMEh8vMNZ2DsgAM68Gnu92jCXOQ@mail.gmail.com>",
        "Subject": "Re: [PATCH v5 2/2] dts: Change hugepage 'amount' to a different term",
        "To": "=?utf-8?q?Juraj_Linke=C5=A1?= <juraj.linkes@pantheon.tech>",
        "Cc": "Bruce Richardson <bruce.richardson@intel.com>,\n Luca Vizzarro <Luca.Vizzarro@arm.com>,\n yoan.picchi@foss.arm.com, paul.szczepanek@arm.com,\n wathsala.vithanage@arm.com,\n thomas@monjalon.net, Honnappa.Nagarahalli@arm.com, probb@iol.unh.edu,\n dev@dpdk.org",
        "Content-Type": "text/plain; charset=\"UTF-8\"",
        "Content-Transfer-Encoding": "quoted-printable",
        "X-BeenThere": "dev@dpdk.org",
        "X-Mailman-Version": "2.1.29",
        "Precedence": "list",
        "List-Id": "DPDK patches and discussions <dev.dpdk.org>",
        "List-Unsubscribe": "<https://mails.dpdk.org/options/dev>,\n <mailto:dev-request@dpdk.org?subject=unsubscribe>",
        "List-Archive": "<http://mails.dpdk.org/archives/dev/>",
        "List-Post": "<mailto:dev@dpdk.org>",
        "List-Help": "<mailto:dev-request@dpdk.org?subject=help>",
        "List-Subscribe": "<https://mails.dpdk.org/listinfo/dev>,\n <mailto:dev-request@dpdk.org?subject=subscribe>",
        "Errors-To": "dev-bounces@dpdk.org"
    },
    "addressed": null
}