mbox series

[v4,0/1] mbuf: add bulk free function

Message ID 20191007101427.16191-1-mb@smartsharesystems.com (mailing list archive)
Headers
Series mbuf: add bulk free function |

Message

Morten Brørup Oct. 7, 2019, 10:14 a.m. UTC
  Add function for freeing a bulk of mbufs.

v4:
* Marked as experimental by adding __rte_experimental.
* Add function to experimental section of map file.
* Fix source code formatting regarding pointer to pointer.
* Squashed multiple modifications into one.
v3:
* Bugfix: Handle pakets with multiple segments.
* Added inline helper function, mainly for readability.
* Fix source code formatting regarding indentation.
v2:
* Function is not inline.
* Optimized to free multible mbufs belonging to the same mempool in
bulk. Inspired by ixgbe_tx_free_bufs(), but allowing NULL pointers
in the array, just like rte_pktmbuf_free() can take a NULL pointer.
* Use unsigned int instead of unsigned. Passes checkpatch, but
mismatches the original coding style of the modified files.
* Fixed a typo in the description headline: mempools is plural.

Morten Brørup (1):
  mbuf: add bulk free function

 lib/librte_mbuf/rte_mbuf.c           | 50 ++++++++++++++++++++++++++++
 lib/librte_mbuf/rte_mbuf.h           | 12 +++++++
 lib/librte_mbuf/rte_mbuf_version.map |  1 +
 3 files changed, 63 insertions(+)