From patchwork Wed Oct 23 10:11:09 2019 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 8bit X-Patchwork-Submitter: =?utf-8?q?Morten_Br=C3=B8rup?= X-Patchwork-Id: 61720 Return-Path: X-Original-To: patchwork@dpdk.org Delivered-To: patchwork@dpdk.org Received: from [92.243.14.124] (localhost [127.0.0.1]) by dpdk.org (Postfix) with ESMTP id 4BF421BFEF; Wed, 23 Oct 2019 12:11:17 +0200 (CEST) Received: from smartserver.smartsharesystems.com (smartserver.smartsharesystems.com [77.243.40.215]) by dpdk.org (Postfix) with ESMTP id 936201BFE7 for ; Wed, 23 Oct 2019 12:11:16 +0200 (CEST) Received: from dkrd2.smartsharesys.local ([192.168.4.12]) by smartserver.smartsharesystems.com with Microsoft SMTPSVC(6.0.3790.4675); Wed, 23 Oct 2019 12:11:16 +0200 From: =?utf-8?q?Morten_Br=C3=B8rup?= To: dev@dpdk.org Cc: olivier.matz@6wind.com, stephen@networkplumber.org, harry.van.haaren@intel.com, konstantin.ananyev@intel.com, mattias.ronnblom@ericsson.com, bruce.richardson@intel.com, arybchenko@solarflare.com, =?utf-8?q?Morten_Br=C3=B8rup?= Date: Wed, 23 Oct 2019 10:11:09 +0000 Message-Id: <20191023101111.81742-1-mb@smartsharesystems.com> X-Mailer: git-send-email 2.17.1 MIME-Version: 1.0 X-OriginalArrivalTime: 23 Oct 2019 10:11:16.0158 (UTC) FILETIME=[34CC15E0:01D5898A] Subject: [dpdk-dev] [PATCH v9 0/2] mbuf: add bulk free function X-BeenThere: dev@dpdk.org X-Mailman-Version: 2.1.15 Precedence: list List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" Add function for freeing a bulk of mbufs. Add unit test for functions for allocating and freeing a bulk of mbufs. Signed-off-by: Morten Brørup Acked-by: Konstantin Ananyev Reviewed-by: Andrew Rybchenko Acked-by: Stephen Hemminger Acked-by: Olivier Matz --- v9: * Fix a typo in a description. * In the unit test, make chain length a #define and add a few RTE_BUILD_BUG_ON(). * The unit test prints when allocating the mbuf pools for the bulk tests. Also print when freeing them. v8: * Add unit test, covering both bulk alloc and bulk free. v7: * Squash multiple modifications into one. v6: * Remove __rte_always_inline from static function. The compiler will inline anyway. v5: * Rename variables from "free" to "pending" for improved readability. * Add prefix __ to rte_pktmbuf_free_seg_via_array(). * Add array size parameter to __rte_pktmbuf_free_seg_via_array(). The compiler will optimize the parameter away anyway. * Add description to __rte_pktmbuf_free_seg_via_array(). * Minor description updates. v4: * Mark as experimental by adding __rte_experimental. * Add function to experimental section of map file. * Fix source code formatting regarding pointer to pointer. * Squash multiple modifications into one. v3: * Bugfix: Handle pakets with multiple segments. * Add inline helper function, mainly for readability. * Fix source code formatting regarding indentation. v2: * Function is not inline. * Optimize to free multible mbufs belonging to the same mempool in bulk. Inspired by ixgbe_tx_free_bufs(), but allowing NULL pointers in the array, just like rte_pktmbuf_free() can take a NULL pointer. * Use unsigned int instead of unsigned. Passes checkpatch, but mismatches the original coding style of the modified files. * Fix a typo in the description headline: mempools is plural. Morten Brørup (2): mbuf: add bulk free function mbuf: add unit test for bulk alloc/free functions app/test/test_mbuf.c | 179 +++++++++++++++++++++++++++ lib/librte_mbuf/rte_mbuf.c | 66 ++++++++++ lib/librte_mbuf/rte_mbuf.h | 15 +++ lib/librte_mbuf/rte_mbuf_version.map | 1 + 4 files changed, 261 insertions(+)