mbox

[v3,0/3] mbuf: add bulk free function

Message ID 20190927100513.105674-1-mb@smartsharesystems.com (mailing list archive)
Headers

Message

Morten Brørup Sept. 27, 2019, 10:05 a.m. UTC
  Add function for freeing a bulk of mbufs.

v3:
* Bugfix: Handle pakets with multiple segments.
* Added inline helper function, mainly for readability.
* Fix source code formatting regarding indentation.
v2:
* Function is not inline.
* Optimized to free multible mbufs belonging to the same mempool in
bulk. Inspired by ixgbe_tx_free_bufs(), but allowing NULL pointers
in the array, just like rte_pktmbuf_free() can take a NULL pointer.
* Use unsigned int instead of unsigned. Passes checkpatch, but
mismatches the original coding style of the modified files.
* Fixed a typo in the description headline: mempools is plural.

Morten Brørup (3):
  mbuf: add bulk free function
  mbuf: add bulk free function
  mbuf: add bulk free function

 lib/librte_mbuf/rte_mbuf.c | 50 ++++++++++++++++++++++++++++++++++++++
 lib/librte_mbuf/rte_mbuf.h | 11 +++++++++
 2 files changed, 61 insertions(+)