mbox

[0/4] Clarify asymmetric random, add 'k', uint

Message ID 20220202065030.23276-1-arkadiuszx.kusztal@intel.com (mailing list archive)
Headers

Message

Arkadiusz Kusztal Feb. 2, 2022, 6:50 a.m. UTC
  This patchset introduces following changes:

1) DSA 'k' was added that devices withouth random support can work.
2) Clarified usage of random numbers in asym, as per discussion
from December.
3) Added typedef for crypto_uint to remove some repeating
comments making code more readable. Additionally some rearrangement
were made to improve readibility.

Arek Kusztal (4):
  crypto: add dsa random number k
  crypto: clarify usage of random numbers in asym
  crypto: use rte macro instead of direct attribute
  crypto: reorganize endianness comments, add crypto uint

 lib/cryptodev/rte_crypto_asym.h | 363 ++++++++++++++++------------------------
 1 file changed, 141 insertions(+), 222 deletions(-)