mbox

[v3,0/4] Clarify asymmetric random, add 'k' and crypto uint

Message ID 20220211160238.90065-1-arkadiuszx.kusztal@intel.com (mailing list archive)
Headers

Message

Arkadiusz Kusztal Feb. 11, 2022, 4:02 p.m. UTC
  This patchset introduces following changes:

1) DSA 'k' was added that devices without random support can work.
2) Clarified usage of random numbers in asym, as per discussion from December.
3) Added typedef for crypto_uint to remove some repeating comments making code more readable. Additionally, some rearrangement was made to improve readability.

v2:
- added patches justification to each commit
v3:
- add abidiff ignore hint for rte_crypto_asym_op

Arek Kusztal (4):
  crypto: add dsa random number k
  crypto: clarify usage of random numbers in asym
  crypto: use rte macro instead of direct attribute
  crypto: reorganize endianness comments, add crypto uint

 devtools/libabigail.abignore    |   5 +
 lib/cryptodev/rte_crypto_asym.h | 363 ++++++++++++++++------------------------
 2 files changed, 146 insertions(+), 222 deletions(-)