From patchwork Mon Sep 25 15:24:09 2017 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: =?utf-8?q?Ga=C3=ABtan_Rivet?= X-Patchwork-Id: 29182 Return-Path: X-Original-To: patchwork@dpdk.org Delivered-To: patchwork@dpdk.org Received: from [92.243.14.124] (localhost [127.0.0.1]) by dpdk.org (Postfix) with ESMTP id 3A9F31B210; Mon, 25 Sep 2017 17:24:56 +0200 (CEST) Received: from mail-wr0-f170.google.com (mail-wr0-f170.google.com [209.85.128.170]) by dpdk.org (Postfix) with ESMTP id CA15D1B1B5 for ; Mon, 25 Sep 2017 17:24:41 +0200 (CEST) Received: by mail-wr0-f170.google.com with SMTP id v109so8442609wrc.1 for ; Mon, 25 Sep 2017 08:24:41 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=6wind-com.20150623.gappssmtp.com; s=20150623; h=from:to:cc:subject:date:message-id:in-reply-to:references :in-reply-to:references; bh=/FwczxRZ92KmGxJ4tJsK2lHPmdwnWOmTRg7RLu0HCIQ=; b=FQu5RBISHc0kGPzFb0B8rNOkNzPOytKldh9RfaN/jn3nvyPHsZUnzN1D5w7Fh0z0eP qOjgwW6/Ol7GMSjZDwo6Ap4Dn0dBKUGnFpLf9P2QFR+jz+w78tUbCEc5Rk36lWiFF0hs hRL+IKcNmSOpmQkjpS12SbI749uaeW3VP1RcVBlMidjQEOSiqOxLQd5gnlVXJrW0b8fc Wn3TLB/b931yiAvzoaQYmdTEMRfm3C01QuuLTpkLmEq5aBsAWt/jY9++FWvC3O9yM+Tv E20XM8YrIHXx/c+KuimDnKsSJxrOuT+OHFcFt2PaeWOmULsRCzuSMCfWc7R75YnkJLPm yoYg== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:from:to:cc:subject:date:message-id:in-reply-to :references:in-reply-to:references; bh=/FwczxRZ92KmGxJ4tJsK2lHPmdwnWOmTRg7RLu0HCIQ=; b=M4dP+xQ3DzvCTPQo8XkmfNtu1mgr34KKbqzQxIR5JiWTNwKmpoJfGrxrd/Qh5kONsW aLDmKE8ANCfU6ky9tEnuk9fWceEmu0A1BAYP0gaBj2FrQSj+nJ3829fG7IYcyCbmyvnY ofQIL0hpsfAc24rMMs/6TM8VZmAo4V25ip7vkdUFjoBrinHA3sxkE6W9BBqoegqGE0Ou +aVohvBl/wUVNF6r6ZLQ/NzxrgDe2SLgvZVmsg2UQBTq+IWPDyoSdK5m84v4oyCweVgc DK10NyLP4SBbLEkyZhVt759Eb7sgwqkYIUdYAlPUI2WAj/RNuLedSiV7dhbtT0LI/BFj 8SMA== X-Gm-Message-State: AHPjjUgM3jb9htpF6iYYq4IlYa2Wwnl3fTbVzIQy3tY/rUv+SfJoZTYw beY8SG+g+JhG+0JdU37zQ9H6PkUE X-Google-Smtp-Source: AOwi7QDX91N5xqVDD+tN7bkozs26T+3jq2i6Z3kj0kFMosIDyafhePRXY4LkeoYtIGXddmVEzsbUqg== X-Received: by 10.223.164.22 with SMTP id d22mr7319779wra.7.1506353081039; Mon, 25 Sep 2017 08:24:41 -0700 (PDT) Received: from bidouze.dev.6wind.com (host.78.145.23.62.rev.coltfrance.com. [62.23.145.78]) by smtp.gmail.com with ESMTPSA id o3sm1058933wmg.3.2017.09.25.08.24.39 (version=TLS1_2 cipher=ECDHE-RSA-AES128-SHA bits=128/128); Mon, 25 Sep 2017 08:24:40 -0700 (PDT) From: Gaetan Rivet To: dev@dpdk.org Cc: Gaetan Rivet Date: Mon, 25 Sep 2017 17:24:09 +0200 Message-Id: X-Mailer: git-send-email 2.1.4 In-Reply-To: References: In-Reply-To: References: Subject: [dpdk-dev] [PATCH v3 12/13] pci: deprecate misnamed functions X-BeenThere: dev@dpdk.org X-Mailman-Version: 2.1.15 Precedence: list List-Id: DPDK patches and discussions List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" Rename misnamed functions and describe the change in a deprecation notice. Signed-off-by: Gaetan Rivet --- doc/guides/rel_notes/deprecation.rst | 10 ++++++ lib/librte_pci/include/rte_pci.h | 63 ++++++++++++++++++++++++++++++++++++ lib/librte_pci/rte_pci.c | 26 +++++++++++++++ lib/librte_pci/rte_pci_version.map | 4 +++ 4 files changed, 103 insertions(+) diff --git a/doc/guides/rel_notes/deprecation.rst b/doc/guides/rel_notes/deprecation.rst index 3362f33..1828e57 100644 --- a/doc/guides/rel_notes/deprecation.rst +++ b/doc/guides/rel_notes/deprecation.rst @@ -120,3 +120,13 @@ Deprecation Notices The non-"do-sig" versions of the hash tables will be removed (including the ``signature_offset`` parameter) and the "do-sig" versions renamed accordingly. + +* pci: Several exposed functions are misnamed. + The following functions are deprecated starting from v17.11 and are replaced: + + - ``eal_parse_pci_BDF`` replaced by ``pci_parse_BDF`` + - ``eal_parse_pci_DomBDF`` replaced by ``pci_parse_DomBDF`` + - ``rte_eal_compare_pci_addr`` replaced by ``pci_addr_cmp`` + - ``rte_pci_device_name`` replaced by ``pci_device_name`` + + The functions are only renamed. Their behavior is not affected. diff --git a/lib/librte_pci/include/rte_pci.h b/lib/librte_pci/include/rte_pci.h index 09a609a..224cea0 100644 --- a/lib/librte_pci/include/rte_pci.h +++ b/lib/librte_pci/include/rte_pci.h @@ -127,6 +127,7 @@ struct mapped_pci_resource { TAILQ_HEAD(mapped_pci_res_list, mapped_pci_resource); /** + * @deprecated * Utility function to produce a PCI Bus-Device-Function value * given a string representation. Assumes that the BDF is provided without * a domain prefix (i.e. domain returned is always 0) @@ -143,6 +144,22 @@ int eal_parse_pci_BDF(const char *input, struct rte_pci_addr *dev_addr); /** * Utility function to produce a PCI Bus-Device-Function value + * given a string representation. Assumes that the BDF is provided without + * a domain prefix (i.e. domain returned is always 0) + * + * @param input + * The input string to be parsed. Should have the format XX:XX.X + * @param dev_addr + * The PCI Bus-Device-Function address to be returned. Domain will always be + * returned as 0 + * @return + * 0 on success, negative on error. + */ +int pci_parse_BDF(const char *input, struct rte_pci_addr *dev_addr); + +/** + * @deprecated + * Utility function to produce a PCI Bus-Device-Function value * given a string representation. Assumes that the BDF is provided including * a domain prefix. * @@ -156,6 +173,21 @@ int eal_parse_pci_BDF(const char *input, struct rte_pci_addr *dev_addr); int eal_parse_pci_DomBDF(const char *input, struct rte_pci_addr *dev_addr); /** + * Utility function to produce a PCI Bus-Device-Function value + * given a string representation. Assumes that the BDF is provided including + * a domain prefix. + * + * @param input + * The input string to be parsed. Should have the format XXXX:XX:XX.X + * @param dev_addr + * The PCI Bus-Device-Function address to be returned + * @return + * 0 on success, negative on error. + */ +int pci_parse_DomBDF(const char *input, struct rte_pci_addr *dev_addr); + +/** + * @deprecated * Utility function to write a pci device name, this device name can later be * used to retrieve the corresponding rte_pci_addr using eal_parse_pci_* * BDF helpers. @@ -171,6 +203,22 @@ void rte_pci_device_name(const struct rte_pci_addr *addr, char *output, size_t size); /** + * Utility function to write a pci device name, this device name can later be + * used to retrieve the corresponding rte_pci_addr using eal_parse_pci_* + * BDF helpers. + * + * @param addr + * The PCI Bus-Device-Function address + * @param output + * The output buffer string + * @param size + * The output buffer size + */ +void pci_device_name(const struct rte_pci_addr *addr, + char *output, size_t size); + +/** + * @deprecated * Utility function to compare two PCI device addresses. * * @param addr @@ -186,6 +234,21 @@ int rte_eal_compare_pci_addr(const struct rte_pci_addr *addr, const struct rte_pci_addr *addr2); /** + * Utility function to compare two PCI device addresses. + * + * @param addr + * The PCI Bus-Device-Function address to compare + * @param addr2 + * The PCI Bus-Device-Function address to compare + * @return + * 0 on equal PCI address. + * Positive on addr is greater than addr2. + * Negative on addr is less than addr2, or error. + */ +int pci_addr_cmp(const struct rte_pci_addr *addr, + const struct rte_pci_addr *addr2); + +/** * Map a particular resource from a file. * * @param requested_addr diff --git a/lib/librte_pci/rte_pci.c b/lib/librte_pci/rte_pci.c index cbb5359..54ce10d 100644 --- a/lib/librte_pci/rte_pci.c +++ b/lib/librte_pci/rte_pci.c @@ -73,6 +73,12 @@ get_u8_pciaddr_field(const char *in, void *_u8, char dlm) int eal_parse_pci_BDF(const char *input, struct rte_pci_addr *dev_addr) { + return pci_parse_BDF(input, dev_addr); +} + +int +pci_parse_BDF(const char *input, struct rte_pci_addr *dev_addr) +{ const char *in = input; dev_addr->domain = 0; @@ -91,6 +97,12 @@ eal_parse_pci_BDF(const char *input, struct rte_pci_addr *dev_addr) int eal_parse_pci_DomBDF(const char *input, struct rte_pci_addr *dev_addr) { + return pci_parse_DomBDF(input, dev_addr); +} + +int +pci_parse_DomBDF(const char *input, struct rte_pci_addr *dev_addr) +{ const char *in = input; unsigned long val; char *end; @@ -117,6 +129,13 @@ void rte_pci_device_name(const struct rte_pci_addr *addr, char *output, size_t size) { + pci_device_name(addr, output, size); +} + +void +pci_device_name(const struct rte_pci_addr *addr, + char *output, size_t size) +{ RTE_VERIFY(size >= PCI_PRI_STR_SIZE); RTE_VERIFY(snprintf(output, size, PCI_PRI_FMT, addr->domain, addr->bus, @@ -127,6 +146,13 @@ int rte_eal_compare_pci_addr(const struct rte_pci_addr *addr, const struct rte_pci_addr *addr2) { + return pci_addr_cmp(addr, addr2); +} + +int +pci_addr_cmp(const struct rte_pci_addr *addr, + const struct rte_pci_addr *addr2) +{ uint64_t dev_addr, dev_addr2; if ((addr == NULL) || (addr2 == NULL)) diff --git a/lib/librte_pci/rte_pci_version.map b/lib/librte_pci/rte_pci_version.map index a940259..541769f 100644 --- a/lib/librte_pci/rte_pci_version.map +++ b/lib/librte_pci/rte_pci_version.map @@ -3,7 +3,11 @@ DPDK_17.11 { eal_parse_pci_BDF; eal_parse_pci_DomBDF; + pci_addr_cmp; + pci_device_name; pci_map_resource; + pci_parse_BDF; + pci_parse_DomBDF; pci_unmap_resource; rte_eal_compare_pci_addr; rte_pci_device_name;